Networking

Membatasi Kecepatan Download di Mikrotik

Apabila kita sebagai mengelola warnet, dan terkadang kita bingung apabila ada klien yang melakukan download, sudah pasti akan mengganggu klient yang lain, lalu bagaimana caranya membatasi kecepatan Download di mikrotik tanpa mengganggu klient lain yang sedang browsing ?. Sebenarnya cara mebatasi kecepatan download di mikrotik ini bisa di lakukan dengan simple queue, Tetapi masih ada trik lain yang mesti anda coba, Karena menggunakan simple queue masih ada kelemahannya.

Tips dan trik serupa mungkin banyak anda temukan di paman google, tetapi tidak ada salahnya anda mencoba trik yang saya berikan. karena trik membatasi kecepatan download di Mikrotik ini sudah saya test dan buktikan langsung. Cara kerjanya sebenarnya cukup simple, yaitu membatasi kecepatan Download dengan menggunakan system firewall saat beberapa extensi file yang terdaptar melewati Firewall.

Membatasi Kecepatan Download di Mikrotik

Tentunya untuk melakukan penyaringan extrensi file yang mencoba melewati Firewall, Kita harus melakukan setting Filter firewall. Adapun file extensi yang sering di download seperti file exe, iso, mpg, zip, mov, rar, dat, dan lain sebagainya. bagaimana cara settingnya, anda bisa langsung melakukan copy paste code di bawah ini pada terminal.

Langkah pertama yaitu kita melakukan setting pada firewall. berikut ini Code nya :

 /ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.exe action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.iso action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.mpg action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.zip action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.rar action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.dat action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.flv action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.3gp action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.mpeg action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.avi action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.ram action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.mov action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.wma action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.aiff action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.au action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.wav action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00

/ip firewall filter add chain=forward src-address=192.168.1.0/24 protocol=tcp content=.rar action=add-dst-to-address-list address-list=cekek address-list-timeout=01:00:00
Membatasi Kecepatan Download di Mikrotik
Membatasi Kecepatan Download di Mikrotik

Keterangan Dari code di atas:

  • ” src-address=192.168.1.0/24 ” yang ada di code di atas adalah ip network, oleh karena itu sesuaikan dulu dengan ip network anda,
  • ” tcp content=.rar ” merupakan extensi file yang sering di download oleh client, jika anda merasa kurang, silakan di tambahi sendiri,
  • ” address-list=cekek ” nantinya akan muncul otomatis di menu ip firewall address list dengan nana cekek (di cekik, red) . Blok smua Code di atas kemudian anda paste kan di menu New terminal, akhiri dengan enter.

Langkah berikutnya adalah menginisialisai marking packet di mangle dengan code di bawah ini :

 /ip firewall mangle add chain=forward protocol=tcp src-address-list=cekek action=mark-packet new-packet-mark=cekek-bw-by-extension

 

Membatasi Kecepatan Download di Mikrotik
maksudnya adalah semua traffict tcp yang di kenali pada extension file yang di download akan di mark (ditandai) sebagai cekek-bw-by-extension yang selanjutny akan di kenali di firewall address list sehingga alamat ip yang di download akan terdeteksi otomatis.

Langkah terakhir, adalah memasukkan marking packet yang kita buat di mangle agar di kenali oleh queue dengan memasukkan code dibawah ini

 /queue simple add-files max-limit=32000/64000 packet-marks=cekek-bw-by-extension

 

membatasi-download-di-mikrotik-queu
Membatasi Kecepatan Download di Mikrotik

Artinya kita membatasi download extension file 32kbps upload dan 64kbps dowload. jika bandwitdh anda CEKAK perlu di CEKEK mereka-mereka yang suka ngedownload. Bagi anda yang memiliki bandwitdh besar silakan sesuaikan kapasitas downlod yang ingin anda berikan.. bisa 128kbps, 256kbps 512kbps up to you dah….

Proses Membatasi Kecepatan Download di Mikrotik sudah selesai, silahkan melakukan test dengan melakukan Download di klient dengan mendownload file extensi yang anda masukan di atas. Apabila setelah anda melakukan download kecepatannya terbatas sesuai settingan anda maka semua proses sudah dilakukan dengan benar. Dan apabila belum berhasil, Coba anda cek lagi settingan yang anda lakukan tadi. Terima kasih telah membaca, Semoga bermanfaat.

Silahkan komentar menggunakan akun anda

2 Comments

Tinggalkan Balasan